请选择 进入手机版 | 继续访问电脑版
查看: 970|回复: 9

未来打算升级X3.5的站长有必要留意一下:

[复制链接]

8

主题

593

回帖

888

积分

Giter

贡献
10 点
金币
225 个
发表于 2022-9-15 22:40:51 | 显示全部楼层 |阅读模式
1. 如果你近期打算购买插件或者模板
一定要找开发者打听好,自己购买的插件或者模板能不能保证升级到未来的X3.5正式版

2. 使用GBK的站长需要额外留意插件模板是否区分编码
X3.5只有UTF8版本
因为虽然升级的时候会给GBK提供编码转换,但是插件模板在应用中心的授权不是本地数据,这个自己转换不了的
购买前要跟开发者协商好,未来升级到X3.5的时候开发者能不能提供转授权的服务

3. 如果打算升级到PHP 8.0及以上还需要额外询问好高版本php的兼容情况。
Discuz本体兼容高版本php没问题,不代表插件模板也都可以
目前应用中心似乎显示不出来7.4以上的php支持情况

评分

参与人数 2金币 +8 人气 +8 收起 理由
龙二哥 + 3 + 3 很给力!
zhansh + 5 + 5 赞一个!

查看全部评分

回复

使用道具 举报

8

主题

593

回帖

888

积分

Giter

贡献
10 点
金币
225 个
 楼主| 发表于 2022-9-15 22:53:36 | 显示全部楼层
如果想提前做一些准备的话,可以先从php和mysql版本入手
最稳妥的php版本是7.4(虽然php官方对这个版本也很快就要停止维护了)
最低兼容是到5.6的,因此某些只支持php5的插件用户,建议使用这个版本

php8确实有性能提升,但没有那么明显,兼容性破坏的倒是挺厉害的
这也是X3.4没办法上php8的原因,X3.5为了兼容php8可是改了好多好多地方
没有第三方插件模板拖后腿的话,还是可以上php8的,毕竟新版本安全性和性能都更好

关于MySQL,只要还有条件,就一定不要选择低于5.7的版本(如果是MariaDB则不要低于10.2)
低版本对utf8mb4和InnoDB这种方案的兼容表现并不好,代价就是性能会变得很低下
出于兼容考虑,X3.5还是支持了低版本,但最好不要用。
回复 支持 2 反对 0

使用道具 举报

2

主题

33

回帖

47

积分

初学乍练

贡献
0 点
金币
10 个
QQ
发表于 2022-9-15 22:56:22 | 显示全部楼层
专家 发表于 2022-9-15 22:53
如果想提前做一些准备的话,可以先从php和mysql版本入手
最稳妥的php版本是7.4(虽然php官方对这个版本也很 ...

支持一下~
回复 支持 反对

使用道具 举报

14

主题

543

回帖

760

积分

自成一派

贡献
18 点
金币
72 个
发表于 2022-9-16 02:27:34 | 显示全部楼层
先等等看
回复

使用道具 举报

11

主题

52

回帖

68

积分

渐入佳境

贡献
0 点
金币
3 个
发表于 2022-9-17 00:09:13 | 显示全部楼层
谢谢分享  好帖子
回复 支持 反对

使用道具 举报

8

主题

593

回帖

888

积分

Giter

贡献
10 点
金币
225 个
 楼主| 发表于 2022-9-17 17:11:34 | 显示全部楼层

这里讲的不是现在,而是为将来做准备的,也是提前保障一下自己的利益嘛
回复 支持 反对

使用道具 举报

7

主题

126

回帖

211

积分

炉火纯青

贡献
0 点
金币
59 个
发表于 2022-9-17 20:57:11 | 显示全部楼层
很及时的建议,避免后面走弯路。
回复 支持 反对

使用道具 举报

1

主题

5

回帖

17

积分

初学乍练

贡献
0 点
金币
10 个
发表于 2022-9-18 19:25:07 | 显示全部楼层
来升级到X3.5的时候确实要注意
回复 支持 反对

使用道具 举报

25

主题

527

回帖

612

积分

自成一派

贡献
4 点
金币
27 个
发表于 2022-9-23 11:09:36 | 显示全部楼层
这个建议看到的有点晚!
回复 支持 反对

使用道具 举报

0

主题

6

回帖

16

积分

初学乍练

贡献
0 点
金币
10 个
发表于 2022-9-23 11:56:51 | 显示全部楼层
谢谢对淘客家的提醒,记住了。谢谢
回复 支持 反对

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

添加有偿服务QQ
添加有偿服务微信