Discuz!应用商城(DisMall)Discuz!应用商城(DisMall)

 找回密码
 立即注册

QQ登录

只需一步,快速开始

搜索
热搜: 活动 交友 discuz
查看: 1251|回复: 4

[求助] 安装discuz3.4求助

[复制链接]

2

主题

2

帖子

3

积分

Newbie

Rank: 1

贡献
0 点
金币
1 个
发表于 2020-11-6 01:48:35 | 显示全部楼层 |阅读模式
Fatal error: Call to undefined function is_https() in /www/wwwroot/gumauqur.com/install/index.php on line 61不知道怎么回事
回复

使用道具 举报

0

主题

2

帖子

2

积分

Newbie

Rank: 1

贡献
0 点
金币
0 个
发表于 2021-2-1 19:02:38 | 显示全部楼层
请问楼主,问题解决了吗?我遇到相同的问题。
回复 支持 反对

使用道具 举报

0

主题

988

帖子

1031

积分

开发者

啦啦啦~

Rank: 6Rank: 6Rank: 6

贡献
2 点
金币
8 个
发表于 2021-2-1 21:40:43 | 显示全部楼层
本帖最后由 老周部落 于 2021-2-1 21:47 编辑
tinaresolve 发表于 2021-2-1 19:02
请问楼主,问题解决了吗?我遇到相同的问题。

您好,您的安装包是从哪里下载的?

另外需要注意的是,如果需要重新安装 Discuz! X3.4 ,您需要上传压缩包 upload 目录下的所有文件,而不是仅仅上传 install/index.php 而已。

老周博客
本人不在任何渠道提供任何付费技术支持服务, 谨防上当受骗.
回复 支持 反对

使用道具 举报

0

主题

2

帖子

2

积分

Newbie

Rank: 1

贡献
0 点
金币
0 个
发表于 2021-2-3 17:02:53 | 显示全部楼层
老周部落 发表于 2021-2-1 21:40
您好,您的安装包是从哪里下载的?

另外需要注意的是,如果需要重新安装 Discuz! X3.4 ,您需要上传压缩 ...

谢谢解答,在https://gitee.com/Discuz/DiscuzX/attach_files下载的是Discuz! X3.4R20210119的版本。
后来找到原因了,是因为安装XAMPP的版本过高导致的。最新版X3.4,对PHP版本有要求,PHP最低要求5.3,最高7.4(R20210119 版本不兼容5.3,推荐用5.6起)。
之前安装的是PHP8.0.1版本,后来换成PHP7.4正常安装就不会出现上面的Call to undefined function is_https() in /www/wwwroot/gumauqur.com/install/index.php on line XXX问题了。安装完成后,论坛可以正常运行。
回复 支持 反对

使用道具 举报

0

主题

988

帖子

1031

积分

开发者

啦啦啦~

Rank: 6Rank: 6Rank: 6

贡献
2 点
金币
8 个
发表于 2021-2-3 17:08:44 | 显示全部楼层
tinaresolve 发表于 2021-2-3 17:02
谢谢解答,在https://gitee.com/Discuz/DiscuzX/attach_files下载的是Discuz! X3.4R20210119的版本。
后 ...

是的,X3.4 不兼容 PHP 8 。
老周博客
本人不在任何渠道提供任何付费技术支持服务, 谨防上当受骗.
回复 支持 反对

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

手机版|小黑屋|Discuz!应用中心 ( 皖ICP备16010102号 )|网站地图star

GMT+8, 2022-5-26 15:56 , Processed in 0.062370 second(s), 22 queries , Yac On.

Powered by Discuz!

Copyright © Tencent Cloud.

快速回复 返回顶部 返回列表