Discuz!应用商城(DisMall)Discuz!应用商城(DisMall)

 找回密码
 立即注册
搜索
热搜: 活动 交友 discuz
查看: 786|回复: 4

[杂谈] 请问需要php5.2~php7.0是不是范围内都支持

[复制链接]

6

主题

13

帖子

19

积分

Newbie

Rank: 1

贡献
0 点
金币
5 个
发表于 2021-4-1 10:42:14 来自手机版 | 显示全部楼层 |阅读模式
新手不太懂。我的空间脚本语言是php5.2~php7.0
数据库版本是5.5。请问能用3.5吗?如果安装3.5能正常使用吗?
回复

使用道具 举报

42

主题

1899

帖子

2159

积分

管理员

Rank: 9Rank: 9Rank: 9

贡献
0 点
金币
143 个
发表于 2021-4-1 10:48:22 | 显示全部楼层
不能,X3.5要求mysql版本5.7+
回复 支持 反对

使用道具 举报

0

主题

987

帖子

1030

积分

开发者

啦啦啦~

Rank: 6Rank: 6Rank: 6

贡献
2 点
金币
8 个
发表于 2021-4-4 09:11:41 | 显示全部楼层
Killer 发表于 2021-4-1 10:48
不能,X3.5要求mysql版本5.7+

目前 X3.5 调整了一下设计, MySQL 能到 5.5.3 。但是当 MySQL < 5.7 或 MariaDB < 10.2 时, InnoDB 性能下降较为严重,因此在生产系统上运行的站点应升级版本至 MySQL >= 5.7 或 MariaDB >= 10.2 以避免此问题。
老周博客
本人不在任何渠道提供任何付费技术支持服务, 谨防上当受骗.
回复 支持 反对

使用道具 举报

0

主题

987

帖子

1030

积分

开发者

啦啦啦~

Rank: 6Rank: 6Rank: 6

贡献
2 点
金币
8 个
发表于 2021-4-4 09:13:54 | 显示全部楼层
X3.5 要求 PHP >= 5.6.0 (依赖 XML 扩展、 JSON 扩展、 GD 扩展 >= 1.0 ,PHP 8.0 为测试性支持),推荐 PHP 7.3 - 8.0 。MySQL >= 5.5.3 ,推荐 5.7 - 8.0。

但请注意当 MySQL < 5.7 或 MariaDB < 10.2 时, InnoDB 性能下降较为严重,因此在生产系统上运行的站点应升级版本至 MySQL >= 5.7 或 MariaDB >= 10.2 以避免此问题。

根据您的情况的话,选 PHP 7.0 ,完了数据库如果能到 5.5.3 就凑合着,但是效率比较低,做大了要考虑换。
老周博客
本人不在任何渠道提供任何付费技术支持服务, 谨防上当受骗.
回复 支持 反对

使用道具 举报

8

主题

27

帖子

38

积分

Newbie

Rank: 1

贡献
0 点
金币
10 个
发表于 2021-6-16 13:28:31 | 显示全部楼层
Killer 发表于 2021-4-1 10:48
不能,X3.5要求mysql版本5.7+

mysql版本具体是5。7几呢  php7点几呢
回复 支持 反对

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

手机版|小黑屋|Discuz!应用中心 ( 皖ICP备16010102号 )|网站地图star

GMT+8, 2022-5-18 04:31 , Processed in 0.029725 second(s), 9 queries , Yac On.

Powered by Discuz!

Copyright © Tencent Cloud.

快速回复 返回顶部 返回列表