请选择 进入手机版 | 继续访问电脑版
查看: 1094|回复: 3

[已解决] mysql_connect不支持

[复制链接]

2

主题

5

帖子

5

积分

Newbie

Rank: 1

贡献
0 点
金币
0 个
发表于 2021-8-26 18:39:37 | 显示全部楼层 |阅读模式
U5cuhzr50yvY3M5.jpg
把PHP从5.3设置到了7.3  然后用DZ的插件检测到mysql_connect不支持,这个会影响论坛程序插件这些吗
我知道答案 回答被采纳将会获得5 金币 已有3人回答
回复

使用道具 举报

81

主题

2876

帖子

3480

积分

Forum Legend

Rank: 6Rank: 6Rank: 6

贡献
8 点
金币
339 个
发表于 2021-8-26 19:48:44 | 显示全部楼层
用了PHP7.3,发现和PHP5变化还挺大的,最大的就是MySQL的连接库变了。

PHP5中使用mysql_connect()函数进行连接,但实际上,PHP5.5开始,MySQL就不推荐使用了,属于废弃函数

PHP7.3中貌似已经彻底不支持了,根据官网说明,取而代之的是如下两个:

本扩展自 PHP 5.5.0 起已废弃,并在将来会被移除。应使用 MySQLi 或 PDO_MySQL 扩展来替换之。参见 MySQL:选择
API 指南以及相关 FAQ 以获取更多信息。用以替代本函数的有:
mysqli_connect()PDO::__construct()
使用时,不要在使用mysql_connect了,可以换用mysqli_connect(),用法基本类似吧,据说是面向对象的库。

php.ini中,也只有extension=php_mysqli.dll,而不再有extension=php_mysql.dll这个拓展了。
回复 支持 反对

使用道具 举报

51

主题

1141

帖子

3万

积分

管理员

Rank: 9Rank: 9Rank: 9

贡献
2000 点
金币
1589 个
发表于 2021-8-26 21:14:20 | 显示全部楼层
没影响,老版本php才用mysql_connect
回复 支持 反对

使用道具 举报

2

主题

5

帖子

5

积分

Newbie

Rank: 1

贡献
0 点
金币
0 个
 楼主| 发表于 2021-8-26 21:53:41 | 显示全部楼层
dashen 发表于 2021-8-26 21:14
没影响,老版本php才用mysql_connect

谢谢解答
回复 支持 反对

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

添加有偿服务QQ
添加有偿服务微信