请选择 进入手机版 | 继续访问电脑版
查看: 302|回复: 5

[求助] discuz3.5在选定PHP的问题

[复制链接]

1

主题

2

回帖

8

积分

初学乍练

贡献
0 点
金币
5 个
发表于 2022-11-26 17:05:28 | 显示全部楼层 |阅读模式
最近看大家都在议论Discuz3.5支持PHP8.0和8.1,于是升级了,测试中用于7.4及以下版本没有问题,但是使用PHP8.0和8.1的时候会报这个错误,请问有大神知道这个问题怎么解决嘛? QQ截图20221126165916.png



我知道答案 回答被采纳将会获得5 金币 已有5人回答
回复

使用道具 举报

3

主题

78

回帖

102

积分

渐入佳境

贡献
0 点
金币
19 个
发表于 2022-11-26 22:09:33 | 显示全部楼层
你使用的官方升级文件?
我切换到8.1也报错,但是是插件导致的报错,而不是DZ报错
回复 支持 反对

使用道具 举报

13

主题

80

回帖

134

积分

渐入佳境

贡献
0 点
金币
32 个
发表于 2022-11-26 23:30:09 | 显示全部楼层
目前8.0和8.1 部分空间安装会这个,如果安装 7.4一般没有错

所以稳当点   7.4 吧
回复 支持 反对

使用道具 举报

14

主题

436

回帖

1266

积分

应用开发者

贡献
1 点
金币
801 个
发表于 2022-11-27 10:52:37 | 显示全部楼层
那是因为你没正常升级,UC配置文件缺少常量
回复 支持 反对

使用道具 举报

1

主题

2

回帖

8

积分

初学乍练

贡献
0 点
金币
5 个
 楼主| 发表于 2022-11-28 00:51:01 | 显示全部楼层
1314学习网 发表于 2022-11-27 10:52
那是因为你没正常升级,UC配置文件缺少常量

需要如何正常升级呢,数据库跟dz文件都是按教程做的升级
回复 支持 反对

使用道具 举报

12

主题

27

回帖

48

积分

初学乍练

贡献
0 点
金币
5 个
发表于 2022-11-28 16:31:03 | 显示全部楼层
先备份dz数据,然后完整删除系统,然后重新安装新版dz3.5系统,在恢复你备份数据,这样一般没啥问题,否则自己上传升级文件确实会有问题,我之前也是更新有小错误,最后就这么搞新版就没事了,注意所有文件都提前备份,以防出错
回复 支持 反对

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

添加有偿服务QQ
添加有偿服务微信